On May 20, 2025, between 12:09 PM UTC and 4:07 PM UTC, the GitHub Copilot service experienced degraded availability, specifically for the Claude Sonnet 3.7 model. During this period, the success rate for Claude Sonnet 3.7 requests was highly variable, down to approximately 94% during the most severe spikes. Other models remained available and working as expected throughout the incident. The issue was caused by capacity constraints in our model processing infrastructure that affected our ability to handle the large volume of Claude Sonnet 3.7 requests. We mitigated the incident by rebalancing traffic across our infrastructure, adjusting rate limits, and working with our infrastructure teams to resolve the underlying capacity issues. We are working to improve our infrastructure redundancy and implementing more robust monitoring to reduce detection and mitigation time for similar incidents in the future.
Posted May 20, 2025 - 16:08 UTC
Update
Copilot is operating normally.
Posted May 20, 2025 - 16:08 UTC
Update
The issues with our upstream model provider have been resolved, and Claude Sonnet 3.7 is once again available in Copilot Chat, VS Code and other Copilot products.
We will continue monitoring to ensure stability, but mitigation is complete.
Posted May 20, 2025 - 16:07 UTC
Update
We are continuing to work with our model providers on mitigations to increase the success rate of Sonnet 3.7 requests made via Copilot.
Posted May 20, 2025 - 14:59 UTC
Update
We’re still working with our model providers on mitigations to increase the success rate of Sonnet 3.7 requests made via Copilot.
Posted May 20, 2025 - 14:15 UTC
Update
We are experiencing degraded availability for the Claude Sonnet 3.7 model in Copilot Chat, VS Code and other Copilot products. This is due to an issue with an upstream model provider. We are working with them to resolve the issue.
Other models are available and working as expected.
Posted May 20, 2025 - 13:33 UTC
Investigating
We are investigating reports of degraded performance for Copilot